aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 34 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..6814e48
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,34 @@
+dnl guile-xapian --- Guile bindings for Xapian
+dnl Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
+dnl
+dnl This file is part of guile-xapian.
+dnl
+dnl guile-xapian is free software: you can redistribute it and/or
+dnl modify it under the terms of the GNU General Public License as
+dnl published by the Free Software Foundation, either version 2 of the
+dnl License, or (at your option) any later version.
+dnl
+dnl guile-xapian is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+dnl General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU General Public License
+dnl along with guile-xapian. If not, see
+dnl <https://www.gnu.org/licenses/>.
+
+AC_INIT([guile-xapian], [0.1.0])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign check-news no-dist-gzip dist-lzip])
+AM_SILENT_RULES([yes])
+LT_INIT
+
+AC_PROG_CXX
+AX_PKG_SWIG
+PKG_CHECK_MODULES([GUILE], [guile-2.2])
+GUILE_PROGS
+PKG_CHECK_MODULES([XAPIAN], [xapian-core])
+PKG_CHECK_MODULES([ZLIB], [zlib])
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+AC_OUTPUT