aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5d717ca..625f270 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# guile-xapian --- Guile bindings for Xapian
-# Copyright © 2020, 2021, 2022, 2023 Arun Isaac <arunisaac@systemreboot.net>
+# Copyright © 2020–2024 Arun Isaac <arunisaac@systemreboot.net>
# Copyright © 2022 Bob131 <bob@bob131.so>
#
# This file is part of guile-xapian.
@@ -18,6 +18,8 @@
# along with guile-xapian. If not, see
# <https://www.gnu.org/licenses/>.
+GPG = gpg
+
# Prefix variables for silencing various commands. See "(automake)
# Automake Silent Rules" for details.
@@ -90,6 +92,9 @@ SCM_LOG_DRIVER = \
EXTRA_DIST = $(TESTS) $(SOURCES) except.i xapian.i.in xapian-head.i xapian-headers.i
+%.asc: %
+ $(GPG) --detach-sign --armor $<
+
# Build website
website: website/index.html