aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-09-02 22:26:46 +0530
committerArun Isaac2021-09-02 22:30:23 +0530
commitcb61a526c82153c09ed357901166a42b48ba9d3b (patch)
tree2cdeaea5284297ca005f2fc703ee518fc47b9065 /Makefile.am
parent12f12fbcb3cba4c634e10e7bf16a5c47d670f83b (diff)
downloadguile-xapian-cb61a526c82153c09ed357901166a42b48ba9d3b.tar.gz
guile-xapian-cb61a526c82153c09ed357901166a42b48ba9d3b.tar.lz
guile-xapian-cb61a526c82153c09ed357901166a42b48ba9d3b.zip
website: Add website.
* website/style.css: New file. * build-aux/build-home-page.el: New file. * configure.ac: Look for emacs. * Makefile.am (EMACS_GEN, EMACS_GEN_, EMACS_GEN_0, EMACS_GEN_1): New variables. (website, website/index.html): New target. (CLEANFILES): Add website/index.html. * .gitignore: Add website/index.html.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 71f83da..c06bc57 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,6 +17,14 @@
# along with guile-xapian. If not, see
# <https://www.gnu.org/licenses/>.
+# Prefix variables for silencing various commands. See "(automake)
+# Automake Silent Rules" for details.
+
+EMACS_GEN = $(EMACS_GEN_$(V))
+EMACS_GEN_ = $(EMACS_GEN_$(AM_DEFAULT_VERBOSITY))
+EMACS_GEN_0 = @echo " EMACS" $@;
+EMACS_GEN_1 =
+
# Xapian wrapper
lib_LTLIBRARIES = libguilexapian.la
@@ -55,3 +63,11 @@ SUFFIXES = .scm .go
# Building xapian/xapian.scm additionally requires the libguilexapian
# shared library.
xapian/xapian.go: xapian/xapian.scm libguilexapian.la
+
+# Build website
+
+website: website/index.html
+
+CLEANFILES += website/index.html
+website/index.html: README.org
+ $(EMACS_GEN)$(EMACS) -Q --batch --load build-aux/build-home-page.el --funcall build-website