aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2023-01-20 22:34:08 +0000
committerArun Isaac2023-01-20 22:47:12 +0000
commit9df5620f5bbd571a00c1a9aa8567f2efe1974880 (patch)
treeefcba376769bab5b1bca46c8ec431f74b68c2b05 /Makefile.am
parent9e0adc6b9b0108700cfa174d2f68dcfcae5717dd (diff)
downloadguile-xapian-9df5620f5bbd571a00c1a9aa8567f2efe1974880.tar.gz
guile-xapian-9df5620f5bbd571a00c1a9aa8567f2efe1974880.tar.lz
guile-xapian-9df5620f5bbd571a00c1a9aa8567f2efe1974880.zip
Catch C++ xapian exceptions and raise them as scheme exceptions.
Uncaught C++ exceptions crash the guile process without providing scheme code any opportunity to respond. * except.i, xapian/error.scm: New files. * xapian.i.in: Include except.i. * Makefile.am (SOURCES): Add xapian/error.scm. (xapian_wrap.cc xapian/wrap.scm &): Depend on except.i.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e88d63b..7c7785e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# guile-xapian --- Guile bindings for Xapian
-# Copyright © 2020, 2021, 2022 Arun Isaac <arunisaac@systemreboot.net>
+# Copyright © 2020, 2021, 2022, 2023 Arun Isaac <arunisaac@systemreboot.net>
# Copyright © 2022 Bob131 <bob@bob131.so>
#
# This file is part of guile-xapian.
@@ -50,7 +50,7 @@ CLEANFILES = xapian.i xapian_wrap.cc xapian/wrap.scm
xapian.i: xapian.i.in Makefile
sed -e 's|@libdir[@]|$(libdir)|g' -e 's|@GUILE_EFFECTIVE_VERSION[@]|$(GUILE_EFFECTIVE_VERSION)|g' $< > $@
-xapian_wrap.cc xapian/wrap.scm &: xapian.i xapian-head.i xapian-headers.i
+xapian_wrap.cc xapian/wrap.scm &: xapian.i xapian-head.i xapian-headers.i except.i
$(MKDIR_P) xapian
$(SWIG_GEN)$(SWIG) $(SWIG_FLAGS) -I$(srcdir) -scmstub -o xapian_wrap.cc -guile -package xapian -c++ $<
@@ -59,7 +59,7 @@ xapian_wrap.cc xapian/wrap.scm &: xapian.i xapian-head.i xapian-headers.i
moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
godir = $(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
-SOURCES = xapian/wrap.scm xapian/xapian.scm
+SOURCES = xapian/error.scm xapian/wrap.scm xapian/xapian.scm
GOBJECTS = $(SOURCES:%.scm=%.go)
nobase_mod_DATA = $(SOURCES)