aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2020-02-15 19:25:30 +0530
committerArun Isaac2020-02-15 19:34:29 +0530
commit9a1bfc6980fb492149ad795330f0d5b17a3b59cf (patch)
tree54a017fb98582e2c5f1160c08411df58aaa60e98 /Makefile.am
downloadguile-xapian-9a1bfc6980fb492149ad795330f0d5b17a3b59cf.tar.gz
guile-xapian-9a1bfc6980fb492149ad795330f0d5b17a3b59cf.tar.lz
guile-xapian-9a1bfc6980fb492149ad795330f0d5b17a3b59cf.zip
First commit.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..bb1b74f
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,50 @@
+# guile-xapian --- Guile bindings for Xapian
+# Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
+#
+# This file is part of guile-xapian.
+#
+# guile-xapian is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# guile-xapian is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with guile-xapian. If not, see
+# <https://www.gnu.org/licenses/>.
+
+# Xapian wrapper
+
+lib_LTLIBRARIES = libguilexapian.la
+
+BUILT_SOURCES = xapian_wrap.cc
+libguilexapian_la_SOURCES = xapian_wrap.cc
+libguilexapian_la_CXXFLAGS = $(GUILE_CFLAGS) $(XAPIAN_CFLAGS)
+libguilexapian_la_LDFLAGS = $(GUILE_LIBS) $(XAPIAN_LIBS)
+
+xapian_wrap.cc: xapian.i xapian-head.i xapian-headers.i
+ $(SWIG) $(XAPIAN_CFLAGS) -scmstub -o $@ -guile -package xapian -c++ $<
+
+xapian_wrap.scm: xapian_wrap.cc
+
+# Guile code
+
+moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir = $(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
+
+SOURCES = xapian/wrap.scm xapian/xapian.scm
+GOBJECTS = $(SOURCES:%.scm=%.go)
+
+nobase_mod_DATA = $(SOURCES)
+nobase_go_DATA = $(GOBJECTS)
+
+CLEANFILES = $(GOBJECTS)
+EXTRA_DIST = $(SOURCES)
+GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
+SUFFIXES = .scm .go
+.scm.go:
+ $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILD) compile $(GUILE_WARNINGS) -o "$@" "$<"