summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f4d352e..9b999e1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,5 +47,19 @@ SOURCES = \
email/quoted-printable.scm \
email/utils.scm
+TEST_EXTENSIONS = .scm
+
+SCM_TESTS = \
+ tests/quoted-printable.scm
+
+TESTS = $(SCM_TESTS)
+
+SCM_LOG_DRIVER = \
+ $(top_builddir)/pre-inst-env \
+ $(GUILE) --no-auto-compile -s \
+ $(top_builddir)/build-aux/test-driver.scm
+
EXTRA_DIST += \
+ $(TESTS) \
+ build-aux/test-driver.scm \
COPYING