summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Isaac2023-01-03 16:55:56 +0000
committerArun Isaac2023-01-03 17:43:28 +0000
commit7bef05430de5e39bf2937b026d68d63116c46233 (patch)
tree9cc5c384bab5d251ce86eb83b4c47c388684008b /configure.ac
parentfcc36808753a95ae8f6826c102a632a5a395d245 (diff)
downloadguile-email-7bef05430de5e39bf2937b026d68d63116c46233.tar.gz
guile-email-7bef05430de5e39bf2937b026d68d63116c46233.tar.lz
guile-email-7bef05430de5e39bf2937b026d68d63116c46233.zip
Quit the autotools build system.
For a simple package like guile-email, the autotools build system is more trouble than it is worth. We prefer a hand-written Makefile. As the commit summary suggests, the autotools are indeed a bad habit that we must "quit". * Makefile: New file. * Makefile.am, bootstrap.sh, configure.ac, pre-inst-env.in: Delete files. * build-aux/test-corpus.scm.in: Rename to ... * build-aux/test-corpus.scm: ... this. Remove shebang. * build-aux/test-driver.scm.in: Rename to ... * build-aux/test-driver.scm: ... this. Remove autotools specific parts. * guix.scm: Import (guix utils). (guile-email)[arguments]: Add prefix to #:make-flags. Delete configure phase. * .gitignore: Remove INSTALL, Makefile, Makefile.in, aclocal.m4, autom4te.cache, build-aux/install-sh, build-aux/missing, build-aux/test-corpus.scm, config.log, config.status, configure, doc/.dirstamp, pre-inst-env, test-suite.log, tests/*.log and tests/*.trs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 0 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index c418e88..0000000
--- a/configure.ac
+++ /dev/null
@@ -1,33 +0,0 @@
-dnl guile-email --- Guile email parser
-dnl Copyright © 2018, 2019, 2021 Arun Isaac <arunisaac@systemreboot.net>
-dnl
-dnl This file is part of guile-email.
-dnl
-dnl guile-email is free software; you can redistribute it and/or modify
-dnl it under the terms of the GNU Affero General Public License as
-dnl published by the Free Software Foundation; either version 3 of the
-dnl License, or (at your option) any later version.
-dnl
-dnl guile-email is distributed in the hope that it will be useful, but
-dnl WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-dnl Affero General Public License for more details.
-dnl
-dnl You should have received a copy of the GNU Affero General Public
-dnl License along with guile-email. If not, see
-dnl <http://www.gnu.org/licenses/>.
-
-AC_INIT([guile-email], [0.2.2])
-AC_CONFIG_AUX_DIR([build-aux])
-AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign check-news no-dist-gzip dist-lzip])
-AM_SILENT_RULES([yes])
-
-GUILE_PKG([3.0 2.2])
-GUILE_PROGS
-AC_PATH_PROG([EMACS], [emacs])
-
-AC_CONFIG_FILES([Makefile])
-AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
-AC_CONFIG_FILES([build-aux/test-driver.scm])
-AC_CONFIG_FILES([build-aux/test-corpus.scm], [chmod +x build-aux/test-corpus.scm])
-AC_OUTPUT