summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2023-01-03 16:55:56 +0000
committerArun Isaac2023-01-03 17:43:28 +0000
commit7bef05430de5e39bf2937b026d68d63116c46233 (patch)
tree9cc5c384bab5d251ce86eb83b4c47c388684008b /Makefile.am
parentfcc36808753a95ae8f6826c102a632a5a395d245 (diff)
downloadguile-email-7bef05430de5e39bf2937b026d68d63116c46233.tar.gz
guile-email-7bef05430de5e39bf2937b026d68d63116c46233.tar.lz
guile-email-7bef05430de5e39bf2937b026d68d63116c46233.zip
Quit the autotools build system.
For a simple package like guile-email, the autotools build system is more trouble than it is worth. We prefer a hand-written Makefile. As the commit summary suggests, the autotools are indeed a bad habit that we must "quit". * Makefile: New file. * Makefile.am, bootstrap.sh, configure.ac, pre-inst-env.in: Delete files. * build-aux/test-corpus.scm.in: Rename to ... * build-aux/test-corpus.scm: ... this. Remove shebang. * build-aux/test-driver.scm.in: Rename to ... * build-aux/test-driver.scm: ... this. Remove autotools specific parts. * guix.scm: Import (guix utils). (guile-email)[arguments]: Add prefix to #:make-flags. Delete configure phase. * .gitignore: Remove INSTALL, Makefile, Makefile.in, aclocal.m4, autom4te.cache, build-aux/install-sh, build-aux/missing, build-aux/test-corpus.scm, config.log, config.status, configure, doc/.dirstamp, pre-inst-env, test-suite.log, tests/*.log and tests/*.trs.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am92
1 files changed, 0 insertions, 92 deletions
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index 6c29b96..0000000
--- a/Makefile.am
+++ /dev/null
@@ -1,92 +0,0 @@
-# guile-email --- Guile email parser
-# Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
-# Copyright © 2018, 2019, 2021 Arun Isaac <arunisaac@systemreboot.net>
-#
-# This file was adapted from mumi and is part of guile-email.
-#
-# guile-email is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Affero General Public License as
-# published by the Free Software Foundation; either version 3 of the
-# License, or (at your option) any later version.
-#
-# guile-email is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Affero General Public License for more details.
-#
-# You should have received a copy of the GNU Affero General Public
-# License along with guile-email. If not, see
-# <http://www.gnu.org/licenses/>.
-
-GOBJECTS = $(SOURCES:%.scm=%.go)
-
-nobase_mod_DATA = $(SOURCES) $(NOCOMP_SOURCES)
-nobase_go_DATA = $(GOBJECTS)
-
-# Make sure source files are installed first, so that the mtime of
-# installed compiled files is greater than that of installed source
-# files. See
-# <http://lists.gnu.org/archive/html/guile-devel/2010-07/msg00125.html>
-# for details.
-guile_install_go_files = install-nobase_goDATA
-$(guile_install_go_files): install-nobase_modDATA
-
-CLEANFILES = $(GOBJECTS)
-EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
-GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
-SUFFIXES = .scm .go
-.scm.go:
- $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILD) compile $(GUILE_WARNINGS) -o "$@" "$<"
-
-moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
-godir = $(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
-
-SOURCES = \
- email/base64.scm \
- email/email.scm \
- email/quoted-printable.scm \
- email/utils.scm
-
-TEST_EXTENSIONS = .scm
-
-SCM_TESTS = \
- tests/base64.scm \
- tests/email.scm \
- tests/quoted-printable.scm \
- tests/utils.scm
-
-TESTS = $(SCM_TESTS)
-
-SCM_LOG_DRIVER = \
- $(top_builddir)/pre-inst-env \
- $(GUILE) --no-auto-compile -s \
- $(top_builddir)/build-aux/test-driver.scm
-
-info_TEXINFOS = doc/guile-email.texi
-
-EXTRA_DIST += \
- $(TESTS) \
- tests/multipart-email-with-a-8bit-encoding-and-non-utf8-charset-part \
- tests/email-with-8bit-encoding-and-non-utf8-charset \
- build-aux/test-driver.scm.in \
- COPYING \
- README.org
-
-# Build website.
-AM_MAKEINFOHTMLFLAGS = --css-ref=/style.css
-
-website: website/index.html website/manual/dev/en
-
-website/index.html: README.org
- $(MKDIR_P) $(dir $@)
- $(EMACS) -Q --script build-aux/build-website.el
-
-website/manual/dev/en: doc/guile-email.html
- rm -rf $@
- $(MKDIR_P) $(dir $@)
- cp -vr $< $@
-
-# The clean target depends on clean-local. We use clean-local to clean
-# up the website.
-clean-local:
- rm -rf website/index.html website/manual/dev/en