aboutsummaryrefslogtreecommitdiff
path: root/guix.scm
diff options
context:
space:
mode:
authorArun Isaac2022-01-10 16:36:09 +0530
committerArun Isaac2022-01-10 23:32:22 +0530
commit670b0b68602288b44ad459230be4f701140bca66 (patch)
treef317e2b922da71e214109386d53d310d1a461414 /guix.scm
parent51c12b7e58685b70e7cfd9612dac403cf9ee845c (diff)
downloadccwl-670b0b68602288b44ad459230be4f701140bca66.tar.gz
ccwl-670b0b68602288b44ad459230be4f701140bca66.tar.lz
ccwl-670b0b68602288b44ad459230be4f701140bca66.zip
Migrate to hand-written Makefiles.
The autotools are really overkill for a simple Guile project like ccwl. * .gitignore: Delete autotool generated files. Add Makefile.include. * Makefile.am, Makefile, build-aux/distcheck.scm, configure, configure.ac, configure.scm: New files. * NEWS: Rename to NEWS.org. Remove Emacs file-local variable to use org mode. * bootstrap.sh: Delete file. * build-aux/generate-cwl-output.sh.in: Rename to ... * build-aux/generate-cwl-output.sh: ... this. Replace autoconf variables for cwltool and sed. * build-aux/test-driver.scm.in: Rename to ... * build-aux/test-driver.scm: ... this. Do not import (ice-9 getopt-long). (%options): Delete variable. (my-gnu-runner): Do not write to log or trs ports. Accept test files as command-line arguments. Update invocation of my-gnu-runner. Print summary of results. * guix.scm (ccwl)[native-inputs]: Remove autoconf and automake. * pre-inst-env.in: Rename to ... * pre-inst-env: ... this. Replace autoconf variables for guile, abs_top_builddir and abs_top_srcdir. * scripts/ccwl.in: Rename to ... * scripts/ccwl: ... this. Replace autoconf variable for guile.
Diffstat (limited to 'guix.scm')
-rw-r--r--guix.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/guix.scm b/guix.scm
index fbabdd7..0222810 100644
--- a/guix.scm
+++ b/guix.scm
@@ -40,10 +40,6 @@
(inherit guix:ccwl)
(source (local-file %source-dir
#:recursive? #t
- #:select? (git-predicate %source-dir)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ,@(package-native-inputs guix:ccwl)))))
+ #:select? (git-predicate %source-dir)))))
ccwl