aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-10-31 21:52:43 +0530
committerArun Isaac2021-11-02 01:31:37 +0530
commitde4f458df3e58408e1af2375d0f3b3f86b350a73 (patch)
tree8e63d162a10e16cfafc17f7eae1dc3942c1d5942 /Makefile.am
parent43db9a23ee3b0294180eb50eb78d38cd387eb72c (diff)
downloadccwl-de4f458df3e58408e1af2375d0f3b3f86b350a73.tar.gz
ccwl-de4f458df3e58408e1af2375d0f3b3f86b350a73.tar.lz
ccwl-de4f458df3e58408e1af2375d0f3b3f86b350a73.zip
ccwl: Rename graphviz to dot.
What we call "graphviz syntax" is actually the "graphviz dot language". Rename accordingly. * ccwl/graphviz.scm (workflow->graphviz): Rename to workflow->dot. Call graph->dot instead of graph->graphviz. (escape-id): Update docstring to mention dot. (graph->graphviz): Rename to graph->dot. Update docstring to mention dot. * scripts/ccwl.in (main): Accept --to=dot instead of --to=graphviz. Update --help usage information. * Makefile.am (%.dot): Pass --to=dot instead of --to=graphviz.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 083830a..8125079 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -130,7 +130,7 @@ doc/hello.tar.out: doc/hello.tar
# Print out graph for graphviz's dot.
%.dot: %.scm
- $(CCWL_GEN)$(builddir)/pre-inst-env ccwl compile --to=graphviz $< > $@
+ $(CCWL_GEN)$(builddir)/pre-inst-env ccwl compile --to=dot $< > $@
%.png: %.dot
$(DOT_GEN)$(DOT) -Tpng -o$@ $<