aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-10-12 00:56:36 +0530
committerArun Isaac2021-10-12 01:16:34 +0530
commit6a9f39aa381379e406e66ec6f0ba0c68e6ec9660 (patch)
tree7e2822bbdd55219cf45f8a566d55017e4bed387b /Makefile.am
parentba49bd0ddf6970b70a62093f2ec55cee802fb90b (diff)
downloadccwl-6a9f39aa381379e406e66ec6f0ba0c68e6ec9660.tar.gz
ccwl-6a9f39aa381379e406e66ec6f0ba0c68e6ec9660.tar.lz
ccwl-6a9f39aa381379e406e66ec6f0ba0c68e6ec9660.zip
ccwl: Implement compiling to graphviz.
* ccwl/yaml.scm (indent-level): Import (ccwl utils). Move to ... * ccwl/utils.scm (indent-level): ... here. Export indent-level. * ccwl/graphviz.scm: New file. * Makefile.am (SOURCES): Register it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d143f48..dd5d638 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,7 +73,7 @@ godir = $(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
bin_SCRIPTS = scripts/ccwl
-SOURCES = ccwl/ccwl.scm ccwl/cwl.scm ccwl/yaml.scm ccwl/utils.scm
+SOURCES = ccwl/ccwl.scm ccwl/cwl.scm ccwl/graphviz.scm ccwl/yaml.scm ccwl/utils.scm
TEST_EXTENSIONS = .scm
SCM_TESTS = tests/ccwl.scm tests/utils.scm tests/yaml.scm
TESTS = $(SCM_TESTS)