aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-11-29 20:25:24 +0530
committerArun Isaac2021-11-29 20:25:24 +0530
commit5bdb24c18b5d6abed13ad004325b1bf66eaeca74 (patch)
tree3cae8b06ecc0fe2d2073cd134172a088ec89dd91 /Makefile.am
parent7182d280779a14c2f7a991f6f229e4c0d123435f (diff)
downloadccwl-5bdb24c18b5d6abed13ad004325b1bf66eaeca74.tar.gz
ccwl-5bdb24c18b5d6abed13ad004325b1bf66eaeca74.tar.lz
ccwl-5bdb24c18b5d6abed13ad004325b1bf66eaeca74.zip
Makefile: Build software bundles.
* Makefile.am (docker, pack): New targets.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e0d35ad..9250230 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -219,6 +219,15 @@ $(CURRENT_RELEASE): dist distcheck
%.asc: %
gpg --detach-sign --armor $<
+# Build software bundles.
+
+.PHONY: docker pack
+docker:
+ guix pack -RR --format=docker --entry-point=bin/ccwl --expression='(load "guix.scm")'
+
+pack:
+ guix pack -RR --symlink=/opt/gnu/bin=bin --expression='(load "guix.scm")'
+
# The clean target depends on clean-local. Use clean-local to clean up
# several directories. Directories cannot be specified in CLEANFILES.
clean-local: