aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 1 insertions, 13 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f701aa0..e423791 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,19 +7,7 @@ noinst_SCRIPTS = pre-inst-skribilo
CLEANFILES = $(bin_SCRIPTS) $(noinst_SCRIPTS)
-substitute = sed -e 's,[@]guilemoduledir[@],$(guilemoduledir),g' \
- -e 's,[@]abs_top_srcdir[@],$(abs_top_srcdir),g' \
- -e 's,[@]abs_top_builddir[@],$(abs_top_builddir),g' \
- -e 's,[@]prefix[@],$(prefix),g' \
- -e 's,[@]docdir[@],$(docdir),g' \
- -e 's,[@]emacsdir[@],$(emacsdir),g' \
- -e 's,[@]GUILE[@],$(GUILE),g' \
- -e 's,[@]PACKAGE_STRING[@],$(PACKAGE_STRING),g' \
- -e 's,[@]PACKAGE_NAME[@],$(PACKAGE_NAME),g' \
- -e 's,[@]PACKAGE_VERSION[@],$(PACKAGE_VERSION),g' \
- -e 's,[@]PACKAGE_BUGREPORT[@],$(PACKAGE_BUGREPORT),g'
-
-SUFFIXES = .in
+include $(top_srcdir)/substitute.am
.in:
$(substitute) "$^" > "$@.tmp" && \