aboutsummaryrefslogtreecommitdiff
path: root/doc/user/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/user/Makefile.am')
-rw-r--r--doc/user/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
new file mode 100644
index 0000000..33d16ce
--- /dev/null
+++ b/doc/user/Makefile.am
@@ -0,0 +1,22 @@
+BUILT_SOURCES = user.html
+
+skribilo = $(top_srcdir)/src/guile/skribilo.scm
+load_path = $(top_srcdir)/src/guile:$(top_srcdir)/src/guile/skribilo/package
+
+%.html: %.skb
+ GUILE_LOAD_PATH=$(load_path) \
+ $(skribilo) --target html -I ../ -o $@ $<
+
+if HAVE_LOUT
+
+BUILT_SOURCES += user.ps
+
+%.lout: %.skb
+ GUILE_LOAD_PATH=$(load_path) \
+ $(skribilo) --target lout -I ../ -o $@ $<
+
+%.ps: %.lout
+ $(LOUT) -c $(<:%.lout=%) -o $@ $<
+
+endif
+