summaryrefslogtreecommitdiff
path: root/src/guile/skribilo/source/Makefile.am
diff options
context:
space:
mode:
authorLudovic Court`es2007-07-09 12:03:47 +0000
committerLudovic Court`es2007-07-09 12:03:47 +0000
commit1d28b0859878efcc1a204c9f2232926cf74ae380 (patch)
tree25a706c0a9e4c3340da5380d8109f131c65c184d /src/guile/skribilo/source/Makefile.am
parentf9392ad8b5d8af05d7f59757507c94044cc343af (diff)
parenta26d762e7274adac7f828e546e615fab31eb3038 (diff)
downloadskribilo-1d28b0859878efcc1a204c9f2232926cf74ae380.tar.gz
skribilo-1d28b0859878efcc1a204c9f2232926cf74ae380.tar.lz
skribilo-1d28b0859878efcc1a204c9f2232926cf74ae380.zip
Merge from skribilo@sv.gnu.org--2006
Patches applied: * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2 (patch 118-121) * skribilo@sv.gnu.org--2006/skribilo--devo--1.2 (patch 134-137) - Renamed the `coloring' module tree to `source' for consistency. - Fixed the `sui' module. - Moved SUI stuff from `html.scm' to `sui.scm'. - Linted documentation modules. git-archimport-id: lcourtes@laas.fr--2006-libre/skribilo--devo--1.2--patch-84
Diffstat (limited to 'src/guile/skribilo/source/Makefile.am')
-rw-r--r--src/guile/skribilo/source/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/guile/skribilo/source/Makefile.am b/src/guile/skribilo/source/Makefile.am
new file mode 100644
index 0000000..4c961cf
--- /dev/null
+++ b/src/guile/skribilo/source/Makefile.am
@@ -0,0 +1,31 @@
+guilemoduledir = $(GUILE_SITE)/skribilo/source
+dist_guilemodule_DATA = parameters.scm c.scm lisp.scm xml.scm \
+ lisp-lex.scm xml-lex.scm c-lex.scm
+
+
+EXTRA_DIST = lisp-lex.l xml-lex.l c-lex.l
+
+# Building the lexers with SILex. You must previously run
+# `tla build-config ./arch-config' for this to run.
+#
+# Note: Those files should normally be part of the distribution, making
+# this rule useless to the user.
+.l.scm:
+ $(GUILE) -L $(top_srcdir)/src/guile/silex \
+ -c '(load-from-path "lex.scm") (lex "$^" "$@")' && \
+ mv "$@" "$@.tmp" && \
+ echo '(define-module (skribilo source $(^:%.l=%))' > "$@" && \
+ echo ' :use-module (skribilo lib)' >> "$@" && \
+ echo ' :use-module (skribilo source parameters)' \
+ >> "$@" && \
+ echo ' :use-module (srfi srfi-1)' >> "$@" && \
+ echo ' :export (lexer-init lexer' >> "$@" && \
+ echo ' lexer-get-func-column' >> "$@" && \
+ echo ' lexer-get-func-offset' >> "$@" && \
+ echo ' lexer-get-line lexer-getc' >> "$@" && \
+ echo ' lexer-ungetc))' >> "$@" && \
+ cat "$@.tmp" >> "$@" && \
+ rm "$@.tmp"
+
+
+include $(top_srcdir)/guile-lint.am