aboutsummaryrefslogtreecommitdiff
path: root/src/guile/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès2009-03-24 23:28:06 +0100
committerLudovic Courtès2009-03-24 23:28:58 +0100
commitf37487368372c5ab6207e756b4b4ae89c6d145c3 (patch)
treeb9097bfdc18502f1c8bad33c8ca630fba20f54f5 /src/guile/Makefile.am
parent3a72d5b1cf38fc3c579336e76e2b0354dcd4c4ae (diff)
downloadskribilo-f37487368372c5ab6207e756b4b4ae89c6d145c3.tar.gz
skribilo-f37487368372c5ab6207e756b4b4ae89c6d145c3.tar.lz
skribilo-f37487368372c5ab6207e756b4b4ae89c6d145c3.zip
Add experimental `--enable-guile-vm' configure option.
* configure.ac (--enable-guile-vm): New option. (ENABLE_GUILE_VM): New Automake conditional. * guile-vm.am: New file. * src/guile/Makefile.am (SOURCES): New variable, formerly `nobase_dist_module_DATA'. (SOURCES_NOT_COMPILED): New. Include `guile-vm.am'. * NEWS: Update.
Diffstat (limited to 'src/guile/Makefile.am')
-rw-r--r--src/guile/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/src/guile/Makefile.am b/src/guile/Makefile.am
index 51f8aec..5247afb 100644
--- a/src/guile/Makefile.am
+++ b/src/guile/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright 2005, 2006, 2007, 2008 Ludovic Courtès <ludo@gnu.org>
+# Copyright 2005, 2006, 2007, 2008, 2009 Ludovic Courtès <ludo@gnu.org>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -24,7 +24,7 @@ EXTRA_DIST = \
skribilo/utils/images.scm.in skribilo/config.in \
srfi/srfi-64.scm srfi/srfi-64.upstream.scm
-nobase_dist_module_DATA = \
+SOURCES = \
skribilo.scm diff.scm \
skribilo/biblio/bibtex.scm skribilo/biblio/author.scm \
skribilo/biblio/abbrev.scm skribilo/biblio/template.scm \
@@ -44,8 +44,11 @@ nobase_dist_module_DATA = \
skribilo/table.scm skribilo/utils/justify.scm \
skribilo/utils/text-table.scm
-nobase_dist_module_DATA += \
- $(readers) $(engines) $(packages)
+SOURCES += $(readers) $(packages)
+
+# XXX: Currently, engines cannot be compiled due to a VM limitation.
+# See http://thread.gmane.org/gmane.lisp.guile.devel/8240 for details.
+SOURCES_NOT_COMPILED = $(engines)
readers = \
skribilo/reader/skribe.scm skribilo/reader/outline.scm \
@@ -75,14 +78,14 @@ nobase_module_DATA = \
skribilo/config.scm
# Generated files part of the distribution.
-nobase_dist_module_DATA += \
+SOURCES += \
skribilo/source/lisp-lex.scm skribilo/source/xml-lex.scm \
skribilo/source/c-lex.scm
CLEANFILES = $(nobase_module_DATA)
-
include $(top_srcdir)/substitute.am
+include $(top_srcdir)/guile-vm.am
.in.scm:
$(substitute) "$^" > "$@.tmp" && \