aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès2007-12-10 22:39:34 +0100
committerLudovic Courtès2007-12-10 22:39:34 +0100
commita7c8c1edc641a383f26da6d8e696c39bacb4e2ff (patch)
treeb00f429667487239c227957bcb8a0b1a2671cebf /src/Makefile.am
parent4db9e8bbe8d9dabcb80baee9d096e3894f2c57bf (diff)
downloadskribilo-a7c8c1edc641a383f26da6d8e696c39bacb4e2ff.tar.gz
skribilo-a7c8c1edc641a383f26da6d8e696c39bacb4e2ff.tar.lz
skribilo-a7c8c1edc641a383f26da6d8e696c39bacb4e2ff.zip
Add proper `skribilo-config' executable.
* src/Makefile.am (EXTRA_DIST): Add `skribilo-config.in'. (bin_SCRIPTS): Add `skribilo-config'. (substitute): Add new variables. * src/skribilo-config.in: Improve, based on `skribe-config.in'.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3a3b8ee..f701aa0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,8 +1,8 @@
SUBDIRS = guile
-EXTRA_DIST = skribilo.in pre-inst-skribilo.in
+EXTRA_DIST = skribilo.in pre-inst-skribilo.in skribilo-config.in
-bin_SCRIPTS = skribilo
+bin_SCRIPTS = skribilo skribilo-config
noinst_SCRIPTS = pre-inst-skribilo
CLEANFILES = $(bin_SCRIPTS) $(noinst_SCRIPTS)
@@ -10,10 +10,14 @@ CLEANFILES = $(bin_SCRIPTS) $(noinst_SCRIPTS)
substitute = sed -e 's,[@]guilemoduledir[@],$(guilemoduledir),g' \
-e 's,[@]abs_top_srcdir[@],$(abs_top_srcdir),g' \
-e 's,[@]abs_top_builddir[@],$(abs_top_builddir),g' \
+ -e 's,[@]prefix[@],$(prefix),g' \
+ -e 's,[@]docdir[@],$(docdir),g' \
+ -e 's,[@]emacsdir[@],$(emacsdir),g' \
-e 's,[@]GUILE[@],$(GUILE),g' \
-e 's,[@]PACKAGE_STRING[@],$(PACKAGE_STRING),g' \
-e 's,[@]PACKAGE_NAME[@],$(PACKAGE_NAME),g' \
- -e 's,[@]PACKAGE_VERSION[@],$(PACKAGE_VERSION),g'
+ -e 's,[@]PACKAGE_VERSION[@],$(PACKAGE_VERSION),g' \
+ -e 's,[@]PACKAGE_BUGREPORT[@],$(PACKAGE_BUGREPORT),g'
SUFFIXES = .in