aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorLudovic Courtès2012-07-07 13:23:39 +0200
committerLudovic Courtès2012-07-07 13:23:39 +0200
commit28a742fb7573f38c99fc9d2a773f9c9a989a98e5 (patch)
treeed3d785e294ad2a71ff7b4f18e73bb9cd0966d79 /release.nix
parent5571cad0d19af06e98e89254de110d9a4dcde159 (diff)
downloadskribilo-28a742fb7573f38c99fc9d2a773f9c9a989a98e5.tar.gz
skribilo-28a742fb7573f38c99fc9d2a773f9c9a989a98e5.tar.lz
skribilo-28a742fb7573f38c99fc9d2a773f9c9a989a98e5.zip
release: Add `build_without_lout'.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/release.nix b/release.nix
index 47f74c3..6352cad 100644
--- a/release.nix
+++ b/release.nix
@@ -50,6 +50,23 @@ let
inherit buildOutOfSourceTree;
};
+ build_without_lout =
+ { system ? builtins.currentSystem }:
+
+ let
+ pkgs = import <nixpkgs> { inherit system; };
+ greader = (import <guile-reader/release.nix>).build {
+ inherit system;
+ };
+ in
+ pkgs.releaseTools.nixBuild {
+ name = "skribilo-without-lout";
+ src = jobs.tarball;
+ buildInputs = [ greader ]
+ ++ (with pkgs; [ guile guile_lib imagemagick ploticus ]);
+ inherit buildOutOfSourceTree;
+ };
+
build_guile18 =
{ system ? builtins.currentSystem }: