summaryrefslogtreecommitdiff
path: root/doc/user/Makefile.am
diff options
context:
space:
mode:
authorLudovic Court`es2005-11-02 10:08:38 +0000
committerLudovic Court`es2005-11-02 10:08:38 +0000
commitb76d5e1b252967521f210eac10ddbf089dde8c6a (patch)
tree00fc81c51256991c04799d79a749bbdd5b9fad30 /doc/user/Makefile.am
parentba63b8d4780428d9f63f6ace7f49361b77401112 (diff)
parentf553cb65b157b6df9563cefa593902d59301461b (diff)
downloadskribilo-b76d5e1b252967521f210eac10ddbf089dde8c6a.tar.gz
skribilo-b76d5e1b252967521f210eac10ddbf089dde8c6a.tar.lz
skribilo-b76d5e1b252967521f210eac10ddbf089dde8c6a.zip
Cleaned up the source tree and the installation process.
Patches applied: * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-6 Cosmetic changes. * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-7 Removed useless files, integrated packages. * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-8 Removed useless files, integrated packages. * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-9 Moved the STkLos and Bigloo code to `legacy'. * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-10 Installed Autoconf/Automake machinery. Fixed a few things. * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-11 Changes related to source-highlighting and to the manual. git-archimport-id: lcourtes@laas.fr--2004-libre/skribilo--devel--1.2--patch-10
Diffstat (limited to 'doc/user/Makefile.am')
-rw-r--r--doc/user/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
new file mode 100644
index 0000000..33d16ce
--- /dev/null
+++ b/doc/user/Makefile.am
@@ -0,0 +1,22 @@
+BUILT_SOURCES = user.html
+
+skribilo = $(top_srcdir)/src/guile/skribilo.scm
+load_path = $(top_srcdir)/src/guile:$(top_srcdir)/src/guile/skribilo/package
+
+%.html: %.skb
+ GUILE_LOAD_PATH=$(load_path) \
+ $(skribilo) --target html -I ../ -o $@ $<
+
+if HAVE_LOUT
+
+BUILT_SOURCES += user.ps
+
+%.lout: %.skb
+ GUILE_LOAD_PATH=$(load_path) \
+ $(skribilo) --target lout -I ../ -o $@ $<
+
+%.ps: %.lout
+ $(LOUT) -c $(<:%.lout=%) -o $@ $<
+
+endif
+