aboutsummaryrefslogtreecommitdiff
path: root/doc/user/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtes2006-03-19 20:08:40 +0000
committerLudovic Courtes2006-03-19 20:08:40 +0000
commitd43ab320c8c711aef6417d33a33d0b3d2058f690 (patch)
tree7b86cb9f15836f8193a398891a13a9455918e385 /doc/user/Makefile.am
parent8335269810c4de308aa5b8bfd9c1d8300fd280e1 (diff)
downloadskribilo-d43ab320c8c711aef6417d33a33d0b3d2058f690.tar.gz
skribilo-d43ab320c8c711aef6417d33a33d0b3d2058f690.tar.lz
skribilo-d43ab320c8c711aef6417d33a33d0b3d2058f690.zip
Various documentation fixes + completed the doc automake stuff.
* doc/user/Makefile.am (%.html): Added `-P ../img'. (%.lout): Likewise. (SUBDIRS): New. * doc/user/char.skb (Some characters): Use the Lout-specific example for `!' when relevant. * doc/user/figure.skb (The figure markup): Avoid using `example-produce'. * doc/user/slide.skb (dummy-slide-set-output): New. (dummy-slide-output): New. (dummy-slide-vspace-output): New. (dummy-slide-embed-output): New. (Example of Skribilo Slides): Use a processor, as in `document.skb', in order to use the dummy output functions. git-archimport-id: lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-50
Diffstat (limited to 'doc/user/Makefile.am')
-rw-r--r--doc/user/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
index d6ab75f..d53d46c 100644
--- a/doc/user/Makefile.am
+++ b/doc/user/Makefile.am
@@ -1,3 +1,13 @@
+SUBDIRS = src
+
+EXTRA_DIST = bib.skb char.skb colframe.skb document.skb emacs.skb \
+ engine.skb enumeration.skb eq.skb examples.skb figure.skb \
+ font.skb footnote.skb htmle.skb image.skb index.skb \
+ justify.skb latexe.skb lib.skb line.skb links.skb \
+ markup.skb ornament.skb package.skb prgm.skb sectioning.skb \
+ skribe-config.skb skribec.skb skribeinfo.skb slide.skb start.skb \
+ syntax.skb table.skb toc.skb user.skb xmle.skb
+
BUILT_SOURCES = user.html
skribilo = $(top_srcdir)/src/skribilo
@@ -5,7 +15,7 @@ load_path = $(top_srcdir)/src/guile:$(top_srcdir)/src/guile/skribilo/package
%.html: %.skb
GUILE_LOAD_PATH=$(load_path):$$GUILE_LOAD_PATH \
- $(skribilo) --target html -I ../ -o $@ $<
+ $(skribilo) --target html -I ../ -P ../img -o $@ $<
if HAVE_LOUT
@@ -13,7 +23,7 @@ BUILT_SOURCES += user.ps
%.lout: %.skb
GUILE_LOAD_PATH=$(load_path):$$GUILE_LOAD_PATH \
- $(skribilo) --target lout -I ../ -o $@ $<
+ $(skribilo) --target lout -I ../ -P ../img -o $@ $<
%.ps: %.lout
$(LOUT) -c $(<:%.lout=%) -o $@ $<