aboutsummaryrefslogtreecommitdiff
path: root/doc/user/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès2012-07-07 13:06:29 +0200
committerLudovic Courtès2012-07-07 13:21:37 +0200
commit5571cad0d19af06e98e89254de110d9a4dcde159 (patch)
tree4b8b86392ee8d19200f3b080fb4e0611745489be /doc/user/Makefile.am
parentbe2162ada207514c673afcb467097889170a8020 (diff)
downloadskribilo-5571cad0d19af06e98e89254de110d9a4dcde159.tar.gz
skribilo-5571cad0d19af06e98e89254de110d9a4dcde159.tar.lz
skribilo-5571cad0d19af06e98e89254de110d9a4dcde159.zip
Fix build without Lout.
Reported by rvclayton@verizon.net (R. Clayton). * doc/user/Makefile.am (BUILT_SOURCES): Leave empty when !HAVE_LOUT. (skrflags): Add `-e "(define %have-lout? ...)". * doc/user/loute.skb (Additional Markup): Don't evaluate `src/lout-illustration.skb' when not %HAVE-LOUT?. * doc/user/eq.skb (Equation Formatting): Use 'lout as the renderer only when %HAVE-LOUT?. * doc/user/src/eq3.skb: Likewise.
Diffstat (limited to 'doc/user/Makefile.am')
-rw-r--r--doc/user/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
index b2920a5..3c07297 100644
--- a/doc/user/Makefile.am
+++ b/doc/user/Makefile.am
@@ -34,7 +34,13 @@ skrinfo_DATA = skribilo.info
html_DATA = user.html user.sui
dist_html_DATA = skribilo.css \
lobster-1.4.otf junction.ttf
+
+if HAVE_LOUT
BUILT_SOURCES = lout/front-page.lout
+else !HAVE_LOUT
+BUILT_SOURCES =
+endif !HAVE_LOUT
+
CLEANFILES = $(BUILT_SOURCES) $(html_DATA) skribilo.info
# `user.sui' is produced by the HTML engine.
@@ -55,6 +61,11 @@ skrflags += -e "(define %have-ploticus? (= 0 1))" \
-e "(define %ploticus-path (= 0 1))"
endif
+if HAVE_LOUT
+skrflags += -e "(define %have-lout? (= 1 1))"
+else
+skrflags += -e "(define %have-lout? (= 0 1))"
+endif
load_path = $(top_srcdir)/doc/modules
load_compiled_path = $(top_builddir)/doc/modules