aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Court`es2005-11-02 10:08:38 +0000
committerLudovic Court`es2005-11-02 10:08:38 +0000
commitb76d5e1b252967521f210eac10ddbf089dde8c6a (patch)
tree00fc81c51256991c04799d79a749bbdd5b9fad30 /configure.ac
parentba63b8d4780428d9f63f6ace7f49361b77401112 (diff)
parentf553cb65b157b6df9563cefa593902d59301461b (diff)
downloadskribilo-b76d5e1b252967521f210eac10ddbf089dde8c6a.tar.gz
skribilo-b76d5e1b252967521f210eac10ddbf089dde8c6a.tar.lz
skribilo-b76d5e1b252967521f210eac10ddbf089dde8c6a.zip
Cleaned up the source tree and the installation process.
Patches applied: * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-6 Cosmetic changes. * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-7 Removed useless files, integrated packages. * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-8 Removed useless files, integrated packages. * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-9 Moved the STkLos and Bigloo code to `legacy'. * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-10 Installed Autoconf/Automake machinery. Fixed a few things. * lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-11 Changes related to source-highlighting and to the manual. git-archimport-id: lcourtes@laas.fr--2004-libre/skribilo--devel--1.2--patch-10
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..a4bc494
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,36 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(skribilo, 1.2, ludovic.courtes@laas.fr)
+AM_INIT_AUTOMAKE(skribilo, 1.2)
+
+AC_CONFIG_SRCDIR([src/guile/skribilo/reader.scm])
+
+# Look for Guile.
+GUILE_PROGS
+GUILE_SITE_DIR
+
+# Need guile-reader 0.2.
+GUILE_MODULE_REQUIRED([system reader])
+
+# Look for Lout.
+AC_PATH_PROG([LOUT], [lout], [not-found])
+AM_CONDITIONAL([HAVE_LOUT], [test "x$LOUT" != "xnot-found"])
+
+AC_SUBST([SKRIBILO_DOC_DIR], ["$datadir/doc/skribilo"])
+AC_SUBST([SKRIBILO_EXT_DIR], ["$datadir/skribilo/1.2/"])
+AC_SUBST([SKRIBILO_SKR_PATH], ["$GUILE_SITE/"])
+
+AC_OUTPUT([Makefile
+ src/Makefile
+ src/guile/Makefile
+ src/guile/skribilo/Makefile
+ src/guile/skribilo/config.scm
+ src/guile/skribilo/engine/Makefile
+ src/guile/skribilo/reader/Makefile
+ src/guile/skribilo/package/Makefile
+ src/guile/skribilo/skribe/Makefile
+ src/guile/skribilo/coloring/Makefile
+ doc/Makefile
+ doc/user/Makefile])