summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a5d0221..e0d35ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -91,6 +91,8 @@ EXTRA_DIST += \
doc/hello.c.gz \
doc/hello.tar \
doc/hello.txt \
+ doc/spell-check-text.txt \
+ doc/dictionary \
$(DOC_SCM) \
$(DOC_OTHER) \
COPYING \
@@ -137,6 +139,9 @@ doc/hello-world.out: doc/hello-world.cwl $(GENERATE_CWL_OUTPUT)
doc/pass-stdin.out: doc/pass-stdin.cwl doc/hello.txt $(GENERATE_CWL_OUTPUT)
$(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --file $(word 2, $^)
+doc/spell-check.out: doc/spell-check.cwl doc/spell-check-text.txt doc/dictionary $(GENERATE_CWL_OUTPUT)
+ $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --text-file $(word 2, $^) --dictionary $(word 3, $^)
+
doc/hello.tar.out: doc/hello.tar
echo "$$ tar --list --file $(notdir $<)" > $@
tar --list --file $< >> $@