summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3431242..2fc61c7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,3 +63,16 @@ EXTRA_DIST += \
$(TESTS) \
COPYING \
README.org
+
+# Build website
+
+website: website/index.html
+
+website/index.html: README.org
+ mkdir -p $(dir $@)
+ emacs -Q --script build-aux/build-home-page.el
+
+# The clean target depends on clean-local. We use clean-local to clean
+# up the website built by the website target.
+clean-local:
+ rm -rf website