summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f3bf68f..c68e7d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -161,6 +161,18 @@ website/manual/dev/en: doc/ccwl.html
$(MKDIR_P) $(dir $@)
cp -vr $< $@
+# Make release
+
+CURRENT_RELEASE = website/releases/$(firstword $(DIST_ARCHIVES))
+.PHONY: release
+release: $(CURRENT_RELEASE) $(CURRENT_RELEASE).asc
+
+$(CURRENT_RELEASE): dist distcheck
+ cp $(notdir $@) $@
+
+%.asc: %
+ gpg --detach-sign --armor $<
+
# The clean target depends on clean-local. Use clean-local to clean up
# several directories. Directories cannot be specified in CLEANFILES.
clean-local: