summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Isaac2021-04-25 23:42:10 +0530
committerArun Isaac2021-04-26 00:25:06 +0530
commit95f771b096ad7e9728b16c619f3644b177cea4d3 (patch)
treef5b8669cf6c0dc7398e268e1c31ca4aaab3cbd32 /configure.ac
parent9ab2f84cfa1d4e7016dd0aba1fa9a41eec85b4a1 (diff)
downloadccwl-95f771b096ad7e9728b16c619f3644b177cea4d3.tar.gz
ccwl-95f771b096ad7e9728b16c619f3644b177cea4d3.tar.lz
ccwl-95f771b096ad7e9728b16c619f3644b177cea4d3.zip
Add autotools build system.
* Makefile.am, bootstrap.sh, configure.ac, pre-inst-env.in: New files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..2e1f1fe
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,29 @@
+dnl ccwl --- Concise Common Workflow Language
+dnl Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
+dnl
+dnl This file is part of ccwl.
+dnl
+dnl ccwl is free software: you can redistribute it and/or modify it
+dnl under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation, either version 3 of the License, or
+dnl (at your option) any later version.
+dnl
+dnl ccwl is distributed in the hope that it will be useful, but
+dnl WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+dnl General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU General Public License
+dnl along with ccwl. If not, see <https://www.gnu.org/licenses/>.
+
+AC_INIT([ccwl], [0.1.0])
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign check-news no-dist-gzip dist-lzip])
+AM_SILENT_RULES([yes])
+
+GUILE_PKG([3.0 2.2])
+GUILE_PROGS
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+AC_OUTPUT