summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-11-05 23:22:55 +0530
committerArun Isaac2021-11-05 23:25:36 +0530
commite11ce9bdb2b8a54865edb93dc896479dfafba173 (patch)
tree8ccc8f3673dce09e531aa4fd775e7c06b156b3b8 /Makefile.am
parentc86e1b4276fba6dd110dfb91ffead5707a77421d (diff)
downloadccwl-e11ce9bdb2b8a54865edb93dc896479dfafba173.tar.gz
ccwl-e11ce9bdb2b8a54865edb93dc896479dfafba173.tar.lz
ccwl-e11ce9bdb2b8a54865edb93dc896479dfafba173.zip
doc: Add spell check workflow to tutorial.
* doc/ccwl.skb (Tutorial)[Let's write a spell check workflow]: New section. * Makefile.am (doc/spell-check.out): New target. (EXTRA_DIST): Add doc/spell-check-text.txt and doc/dictionary. * doc/dictionary, doc/spell-check-text.txt, doc/spell-check-workflow-1.scm, doc/spell-check-workflow-2.scm, doc/spell-check.scm: New files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a5d0221..e0d35ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -91,6 +91,8 @@ EXTRA_DIST += \
doc/hello.c.gz \
doc/hello.tar \
doc/hello.txt \
+ doc/spell-check-text.txt \
+ doc/dictionary \
$(DOC_SCM) \
$(DOC_OTHER) \
COPYING \
@@ -137,6 +139,9 @@ doc/hello-world.out: doc/hello-world.cwl $(GENERATE_CWL_OUTPUT)
doc/pass-stdin.out: doc/pass-stdin.cwl doc/hello.txt $(GENERATE_CWL_OUTPUT)
$(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --file $(word 2, $^)
+doc/spell-check.out: doc/spell-check.cwl doc/spell-check-text.txt doc/dictionary $(GENERATE_CWL_OUTPUT)
+ $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --text-file $(word 2, $^) --dictionary $(word 3, $^)
+
doc/hello.tar.out: doc/hello.tar
echo "$$ tar --list --file $(notdir $<)" > $@
tar --list --file $< >> $@