summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-04-26 14:00:44 +0530
committerArun Isaac2021-04-26 14:00:44 +0530
commitd9ed716f24cb93086333a789befcfe0ee3ee2a4b (patch)
tree5cb17fbd1b17d16ebb181180f484026bd0e2fd24 /Makefile.am
parent07802af0735ef9f41976961b17110dbd11692c39 (diff)
downloadccwl-d9ed716f24cb93086333a789befcfe0ee3ee2a4b.tar.gz
ccwl-d9ed716f24cb93086333a789befcfe0ee3ee2a4b.tar.lz
ccwl-d9ed716f24cb93086333a789befcfe0ee3ee2a4b.zip
Run tests in autotools build system.
* build-aux/test-driver.scm.in: New file. * configure.ac: Generate build-aux/test-driver.scm. * Makefile.am (TEST_EXTENSIONS): Add .scm. (SCM_TESTS): Add tests/ccwl.scm and tests/yaml.scm. (TESTS): Set to SCM_TESTS. (EXTRA_DIST): Distribute test files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a5e66f9..cabf6cc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,11 +44,20 @@ SOURCES = \
ccwl/yaml.scm \
ccwl/utils.scm
+TEST_EXTENSIONS = .scm
+
+SCM_TESTS = \
+ tests/ccwl.scm \
+ tests/yaml.scm
+
+TESTS = $(SCM_TESTS)
+
SCM_LOG_DRIVER = \
$(top_builddir)/pre-inst-env \
$(GUILE) --no-auto-compile -s \
$(top_builddir)/build-aux/test-driver.scm
EXTRA_DIST += \
+ $(TESTS) \
COPYING \
README.org