summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-07-19 16:23:46 +0530
committerArun Isaac2021-07-19 16:23:46 +0530
commit91906666c9bc2f34d3cab92c8a6a1456c2ec464b (patch)
tree6d78021b6dedb461ca6955b9d4d80c564635c488 /Makefile.am
parent3b3cec0e8be0be245c0f0e8bba8fcc0a608ebe60 (diff)
downloadccwl-91906666c9bc2f34d3cab92c8a6a1456c2ec464b.tar.gz
ccwl-91906666c9bc2f34d3cab92c8a6a1456c2ec464b.tar.lz
ccwl-91906666c9bc2f34d3cab92c8a6a1456c2ec464b.zip
build-aux: Put website building code into a function.
This will be useful when we want build-home-page.el to build both a website and a gemini capsule. * build-aux/build-home-page.el (build-website): New function. * Makefile.am (website/index.html): Call build-website.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c68e7d0..21e9b8d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,7 +154,7 @@ website: website/index.html website/manual/dev/en
CLEANFILES += website/index.html
CLEAN_DIRECTORIES += website/manual
website/index.html: README.org
- $(EMACS_GEN)$(EMACS) -Q --script build-aux/build-home-page.el
+ $(EMACS_GEN)$(EMACS) -Q --batch --load build-aux/build-home-page.el --funcall build-website
website/manual/dev/en: doc/ccwl.html
rm -rf $@