summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-11-02 02:12:00 +0530
committerArun Isaac2021-11-02 02:14:29 +0530
commit8f2b8395367e67aeaf60bf00e47f3421073e3fa3 (patch)
treefe72743ffd2cd3bf8903272014cd7a17140674bf /Makefile.am
parent0f1167d8fa95874d952f44492ed851a031ed8a8c (diff)
downloadccwl-8f2b8395367e67aeaf60bf00e47f3421073e3fa3.tar.gz
ccwl-8f2b8395367e67aeaf60bf00e47f3421073e3fa3.tar.lz
ccwl-8f2b8395367e67aeaf60bf00e47f3421073e3fa3.zip
Makefile: Do not distribute *.out files.
The *.out files are generated by running ccwl workflows. They need not be distributed. * build-aux/find-dependencies.scm (find-dependencies): Return *.out files and *.scm files as different kinds of dependencies. Output *.out and *.scm files separately as DOC_OUT and DOC_SCM instead of together as DOC_OTHER. * Makefile.am (doc/ccwl.info, doc/ccwl.html): Depend on DOC_SCM and DOC_OUT instead of DOC_OTHER. (EXTRA_DIST): Remove DOT_OTHER. Add DOC_SCM.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 888ae98..99d83c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,7 +88,7 @@ EXTRA_DIST += \
tests/input-output-parameters.cwl \
doc/skribilo.scm \
doc/ccwl.skb \
- $(DOC_OTHER) \
+ $(DOC_SCM) \
COPYING \
README.org
@@ -146,10 +146,10 @@ SKRIBILO_FLAGS = --source-path=$(srcdir) --image-path=$(builddir)
CLEANFILES += doc/ccwl.info doc/skribilo.go
CLEAN_DIRECTORIES += doc/ccwl.html
-doc/ccwl.info: doc/ccwl.skb doc/skribilo.go $(DOC_IMAGES) $(DOC_OTHER)
+doc/ccwl.info: doc/ccwl.skb doc/skribilo.go $(DOC_IMAGES) $(DOC_SCM) $(DOC_OUT)
$(SKRIBILO_GEN)$(builddir)/pre-inst-env $(SKRIBILO) $(SKRIBILO_FLAGS) -t info $< -o $@
-doc/ccwl.html: doc/ccwl.skb doc/skribilo.go $(DOC_IMAGES) $(DOC_OTHER)
+doc/ccwl.html: doc/ccwl.skb doc/skribilo.go $(DOC_IMAGES) $(DOC_SCM) $(DOC_OUT)
rm -rf $@
$(MKDIR_P) $@
$(SKRIBILO_GEN)$(builddir)/pre-inst-env $(SKRIBILO) $(SKRIBILO_FLAGS) -t html $< -o $@/index.html