summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-11-04 14:51:36 +0530
committerArun Isaac2021-11-04 15:42:49 +0530
commit88e842958168e149b1d958e1695d4ecc1256812f (patch)
tree62d6e71f699088fdfac56d71fec5b11338cc23f1 /Makefile.am
parent228298decc0a7add154e78213d557da6602c0e5c (diff)
downloadccwl-88e842958168e149b1d958e1695d4ecc1256812f.tar.gz
ccwl-88e842958168e149b1d958e1695d4ecc1256812f.tar.lz
ccwl-88e842958168e149b1d958e1695d4ecc1256812f.zip
build-aux: Use paths relative to top-level in generate-cwl-output.sh.
This removes the assumption that the source tree and the build tree are the same, and is required to support VPATH builds. * build-aux/generate-cwl-output.sh.in: Accept and write to paths relative to the top-level directory. Do not change directory. * Makefile.am (doc/capture-output-file.out, doc/capture-output-file-with-parameter-reference.out, doc/checksum.out, doc/decompress-compile-run.out, doc/pass-stdin.out): Pass relative paths in input arguments.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c6c194..c7ff854 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -106,25 +106,25 @@ CLEAN_DIRECTORIES = doc/cwl-output
GENERATE_CWL_OUTPUT = ./build-aux/generate-cwl-output.sh
doc/capture-output-file.out: doc/capture-output-file.cwl doc/hello.tar $(GENERATE_CWL_OUTPUT)
- $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --archive hello.tar
+ $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --archive doc/hello.tar
doc/capture-output-file-with-parameter-reference.out: doc/capture-output-file-with-parameter-reference.cwl doc/hello.tar $(GENERATE_CWL_OUTPUT)
- $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --archive hello.tar --extractfile hello.txt
+ $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --archive doc/hello.tar --extractfile hello.txt
doc/capture-stdout.out: doc/capture-stdout.cwl $(GENERATE_CWL_OUTPUT)
$(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --message '"Hello World!"'
doc/checksum.out: doc/checksum.cwl doc/hello.txt $(GENERATE_CWL_OUTPUT)
- $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --file hello.txt
+ $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --file doc/hello.txt
doc/decompress-compile-run.out: doc/decompress-compile-run.cwl doc/hello.c.gz $(GENERATE_CWL_OUTPUT)
- $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --compressed-source hello.c.gz
+ $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --compressed-source doc/hello.c.gz
doc/hello-world.out: doc/hello-world.cwl $(GENERATE_CWL_OUTPUT)
$(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --message '"Hello World!"'
doc/pass-stdin.out: doc/pass-stdin.cwl doc/hello.txt $(GENERATE_CWL_OUTPUT)
- $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --file hello.txt
+ $(CWLTOOL_GEN)$(GENERATE_CWL_OUTPUT) $< --file doc/hello.txt
doc/hello.tar.out: doc/hello.tar
echo "$$ tar --list --file $(notdir $<)" > $@