summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-05-24 18:08:35 +0530
committerArun Isaac2021-05-24 18:23:28 +0530
commit24e02ea77b87984e60b06c11875d2f138a85f392 (patch)
tree80aa011d3ab69f8ad9019e834de3acf922283837 /Makefile.am
parent3d3f90d66f801e9ac0e25e32992604c2be1d2750 (diff)
downloadccwl-24e02ea77b87984e60b06c11875d2f138a85f392.tar.gz
ccwl-24e02ea77b87984e60b06c11875d2f138a85f392.tar.lz
ccwl-24e02ea77b87984e60b06c11875d2f138a85f392.zip
Add CSS to website.
* Makefile.am (website/style.css): New target. (website): Require website/style.css. * style.css: New file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2fc61c7..38e49bc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,12 +66,16 @@ EXTRA_DIST += \
# Build website
-website: website/index.html
+website: website/index.html website/style.css
website/index.html: README.org
mkdir -p $(dir $@)
emacs -Q --script build-aux/build-home-page.el
+website/style.css: style.css
+ mkdir -p $(dir $@)
+ cp -v $< $@
+
# The clean target depends on clean-local. We use clean-local to clean
# up the website built by the website target.
clean-local: