summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-05-24 16:42:12 +0530
committerArun Isaac2021-05-24 16:58:09 +0530
commitd4d56c40286a28ecbe0f5dd94629cb4b947153c2 (patch)
treefd9cecd4d3a64947723272b8d51ee0802d3425d6 /Makefile.am
parentb82ce2ea6044ad58ee67ff497b80e0917c2e7c58 (diff)
downloadccwl-d4d56c40286a28ecbe0f5dd94629cb4b947153c2.tar.gz
ccwl-d4d56c40286a28ecbe0f5dd94629cb4b947153c2.tar.lz
ccwl-d4d56c40286a28ecbe0f5dd94629cb4b947153c2.zip
Replace suffix rule with pattern rule.
Suffix rules are deprecated and should not be used. Pattern rules are clearer and more general. * Makefile.am: Replace suffix rule to build scheme files with pattern rule.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e205c47..3431242 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,8 +32,7 @@ $(guile_install_go_files): install-nobase_modDATA
CLEANFILES = $(GOBJECTS)
EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
-SUFFIXES = .scm .go
-.scm.go:
+%.go: %.scm
$(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILD) compile $(GUILE_WARNINGS) -o "$@" "$<"
moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)