summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-07-04 23:37:36 +0530
committerArun Isaac2021-07-04 23:49:56 +0530
commit70049782e787faf3f6c0f54ca8b93d0bc83437ba (patch)
treeb738d865bab9d1d6eaf2c575a0ea1fd9af059083 /Makefile.am
parentd470c081ed7c12c610905bfc4fe1dc37cc797cf2 (diff)
downloadccwl-70049782e787faf3f6c0f54ca8b93d0bc83437ba.tar.gz
ccwl-70049782e787faf3f6c0f54ca8b93d0bc83437ba.tar.lz
ccwl-70049782e787faf3f6c0f54ca8b93d0bc83437ba.zip
doc: Use PNG images instead of SVG.
PNG images are supported by both the info and html engines. * doc/ccwl.skb (Tutorial)[Workflow with multiple steps]: Use PNG images instead of SVG. * Makefile.am (CLEANFILES): Replace doc/*.svg with doc/*.png. (%.svg): Delete rule. (%.png): New rule. * .gitignore: Replace doc/*.svg with doc/*.png.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index ac921b5..e4c562a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -94,7 +94,7 @@ EXTRA_DIST += \
include .depends
-CLEANFILES += doc/*.cwl doc/%.dot doc/*.svg
+CLEANFILES += doc/*.cwl doc/%.dot doc/*.png
%.cwl: %.scm
$(CCWL_GEN)$(builddir)/pre-inst-env ccwl compile $< > $@
@@ -104,8 +104,8 @@ CLEANFILES += doc/*.cwl doc/%.dot doc/*.svg
%.dot: %.cwl
$(CWLTOOL_GEN)$(CWLTOOL) --print-dot $< | $(SED) 's/file:[^#]*#//g' > $@
-%.svg: %.dot
- $(DOT_GEN)$(DOT) -Tsvg -o$@ $<
+%.png: %.dot
+ $(DOT_GEN)$(DOT) -Tpng -o$@ $<
# The info and html targets depend on the info-local and html-local
# targets respectively. So, we use them to extend the info and html