summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-05-24 18:07:35 +0530
committerArun Isaac2021-05-24 18:07:35 +0530
commit3d3f90d66f801e9ac0e25e32992604c2be1d2750 (patch)
tree3c3d2a31161fd2d34bda9e2cd68d3856c5d88265 /Makefile.am
parentfc4769f504ee89bc9cd715df5280083b2ec8fcd5 (diff)
downloadccwl-3d3f90d66f801e9ac0e25e32992604c2be1d2750.tar.gz
ccwl-3d3f90d66f801e9ac0e25e32992604c2be1d2750.tar.lz
ccwl-3d3f90d66f801e9ac0e25e32992604c2be1d2750.zip
Build website from README.org.
* Makefile.am (website, website/index.html, clean-local): New targets. * build-aux/build-home-page.el: New file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3431242..2fc61c7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,3 +63,16 @@ EXTRA_DIST += \
$(TESTS) \
COPYING \
README.org
+
+# Build website
+
+website: website/index.html
+
+website/index.html: README.org
+ mkdir -p $(dir $@)
+ emacs -Q --script build-aux/build-home-page.el
+
+# The clean target depends on clean-local. We use clean-local to clean
+# up the website built by the website target.
+clean-local:
+ rm -rf website