From a1ccddaaeb42999cc8996ce536647037a2dd120c Mon Sep 17 00:00:00 2001
From: Arun Isaac
Date: Sat, 22 Jul 2023 23:44:16 +0100
Subject: klaus: Add python-httpauth.

* guix/forge/klaus.scm: New file.
---
 guix/forge/klaus.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
 create mode 100644 guix/forge/klaus.scm

(limited to 'guix/forge')

diff --git a/guix/forge/klaus.scm b/guix/forge/klaus.scm
new file mode 100644
index 0000000..fcc63a5
--- /dev/null
+++ b/guix/forge/klaus.scm
@@ -0,0 +1,44 @@
+;;; guix-forge --- Guix software forge meta-service
+;;; Copyright © 2023 Arun Isaac <arunisaac@systemreboot.net>
+;;;
+;;; This file is part of guix-forge.
+;;;
+;;; guix-forge is free software: you can redistribute it and/or modify
+;;; it under the terms of the GNU General Public License as published
+;;; by the Free Software Foundation, either version 3 of the License,
+;;; or (at your option) any later version.
+;;;
+;;; guix-forge is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+;;; General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with guix-forge.  If not, see
+;;; <https://www.gnu.org/licenses/>.
+
+(define-module (forge klaus)
+  #:use-module ((gnu packages check) #:select (python-nose))
+  #:use-module (guix build-system pyproject)
+  #:use-module (guix build-system python)
+  #:use-module (guix download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages))
+
+(define-public python-httpauth
+  (package
+    (name "python-httpauth")
+    (version "0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "httpauth" version))
+              (sha256
+               (base32
+                "0qas7876igyz978pgldp5r7n7pis8n4vf0v87gxr9l7p7if5lr3l"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-nose))
+    (home-page "https://github.com/jonashaag/httpauth")
+    (synopsis "WSGI HTTP Digest Authentication middleware")
+    (description "@code{python-httpauth} is WSGI middleware that secures some/all
+routes using HTTP Digest Authentication.")
+    (license license:bsd-2)))
-- 
cgit v1.2.3